Résoudre l’erreur de version PHP lors de la MAJ de WordPress

Lors de la dernière MAJ de WordPress, certains blogueurs hébergés chez OVH ont pu rencontrer une erreur comme celle-ci dans le panneau d’administration, les empêchant de faire la mise à jour de leur plateforme :

version php

Après quelques recherches, j’ai réussi à trouver la solution. Simple et rapide, je vous propose donc un « mini-tuto », réalisable par les plus expérimentés d’entre vous, autant que par les noobs.

1) A l’aide de votre client FTP (j’utilise Filezilla), localisez votre fichier .htaccess à la racine de votre site.

version php

2) Ceci fait, éditez-le et rajoutez la ligne suivante, en tête du fichier : SetEnv PHP_VER 5

On me souffle aussi dans mon oreillette que pour bénéficier de la toute dernière version (5.3), il suffit de mettre SetEnv PHP_VER 5_TEST à la place de la première proposition ci-dessus.

version php

3) Enregistrez le fichier et le tour est joué. Vous devriez pouvoir faire votre MAJ, de façon automatique ou manuelle.

ENJOY !

Un commentaire

  1. Merci pour ce petit tuto
    Attention cependant cela ne marche que pour OVH qui ne propose pas de PHP5 de base sauf modification du Htaccess (ce qui permet de faire fonctionner WordPress)
    Cela n’aura donc aucun effet pour d’autres hébergeurs (1and1, infomaniak etc)

Laisser un commentaire